Report comment

Hi Roboberry,

My wlan0 says "Not associated".
wlan0 is the onboard Pi's wifi. I want wlan0 to be the hostpot and wlan1 (USB dongle) be the internet connection.

My /etc/dhcpcd.conf file looks like:
interface wlan0
denyinterface wlan0
nohook wpa_supplicant
static ip_address=192.168.50.10/24
static routers=192.168.50.1
static domain_name_servers=8.8.8.8

My /etc/iptables-hs file looks like:
#!/bin/bash
iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE
iptables -A FORWARD -i wlan0 -o wlan1 -m state --state RELATED,ESTABLISHED -j A$
iptables -A FORWARD -i wlan1 -o wlan0 -j ACCEPT

I have tried:
sudo systemctl status hostapd, all ok
etc/dnsmasq.conf and /etc/dhcpcd.conf all start with 192.168.50
wpa_cli -i wlan0 status, is not running
sudo systemctl status dnsmasq, it displays an error here, I copy the promt window:
dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset:
Active: active (running) since Wed 2018-07-04 17:40:33 CEST; 14min ago
Process: 497 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (code=
Process: 484 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status=0
Process: 458 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SUCC
Main PID: 496 (dnsmasq)
CGroup: /system.slice/dnsmasq.service
└─496 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -r /ru

jul 04 17:40:32 Opal dnsmasq[496]: advertencia: interfase wlan0 no existe actual
jul 04 17:40:32 Opal dnsmasq-dhcp[496]: DHCP, IP range 192.168.50.150 -- 192.168
jul 04 17:40:32 Opal dnsmasq[496]: direcciónes /etc/hosts - 5 leídas
jul 04 17:40:33 Opal dnsmasq[496]: no servers found in /run/dnsmasq/resolv.conf,
jul 04 17:40:33 Opal dnsmasq[497]: Too few arguments.
jul 04 17:40:33 Opal dnsmasq[497]: Too few arguments.
jul 04 17:40:33 Opal systemd[1]: Started dnsmasq - A lightweight DHCP and cachin
jul 04 17:40:37 Opal dnsmasq[496]: leyendo /run/dnsmasq/resolv.conf
jul 04 17:40:37 Opal dnsmasq[496]: usando nombre de servidor 80.58.61.250#53
jul 04 17:40:37 Opal dnsmasq[496]: usando nombre de servidor 80.58.61.254#53
lines 1-20/20 (END)...skipping...

What should I do?

Thanks in advance man!